Error: Specified VM install not found: type Standard VM, … al cambiar de máquina Virtual en Eclipse


Recientemente, en el entorno de desarrollo Java del trabajo (Eclipse 3.0 + Lomboz plugin + JBoss 4.02) cambié la JVM existente (la 1.4.2_05) por la versión 1.5.0.15

Después de realizar este cambio no fui capaz de realizar el deploy en local de ninguno de mis proyectos, obteniendo el mensaje siguiente : “Launching (Error: Specified VM install not found: type Standard VM, name j2sdk1.4.2_05)”

Finalmente y después de 4 horas buscando en Google y otros sitios, Mario, un compañero, ha dado con la solución :

  1. Abrir Eclipse
  2. Acceder al menú “Run” –> “External Tools” y abrir “External Tools”. Aparece una ventana que, a mano izquierda y bajo la categoría “Ant Build” lista un fichero .xml para cada uno de nuestros proyectos en el workspace.
  3. Clickar sobre cada uno de los proyectos y en la pestaña “JRE” seleccionar el radio-button denominado “Run in the same JRE as the workspace”. Clickar sobre Apply y seguidamente sobre “Run”. Cada uno de los proyectos se deployará correctamente.

Bueno, espero que esto evite que otros malgasten su tiempo tratando de corregir este puñetero error.

Saludos.

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s